Cloud accounting data may attribute VMs to wrong Group
Symptom
When running Cloud Accounting-related commands, VMs may be attributed to the wrong group, usually 0 (oneadmin).
Conditions
When running hypercloud acct
or hypercloud acct-csv
commands, VMs show up in the wrong group
even after confirming correct group ownership.
Root Cause
This issue is caused by truncated or missing VM history logs. This can be caused by many reasons, to include the dashboard running out of disk space when trying to create a VM history log, HyperCloud being restarted while creating a VM history log, or the dashboard being rebooted while trying to create a VM history log. Additional causes are being investigated.
Workaround
Manually live migrate the impacted virtual machine to create new VM history.
Alternatively, this issue may be worked around by performing the following command
from the dashboard to reboot all compute nodes: hypercloud-reboot-cluster-live -compute